手机版
你好,游客 登录 注册
背景:
阅读新闻

yum安装php Requires: libzip5(x86

[日期:2018-12-21 14:43:58] 来源:linux公社   作者:linux公社 [字体: ]

在做实验时,使用rpm包安装php时,系统自带的版本总是很旧。想安装新版本的php rpm包时,又发现各种依赖包版本达不到要求。

Error: Package: php-pecl-zip-1.15.2-1.el6.remi.5.6.x86_64 (remi) Requires: libzip5(x86-64) = 1.3.2Error: Package: php-pecl-zip-1.15.2-1.el6.remi.5.6.x86_64 (remi) Requires: libzip.so.5()(64bit)

所以,只能从remi源来获取php,但是只配置remi还不够,因为它只有php各个版本相关的包,其他依赖包(如libzip5)和相关工具(如php-fpm)都放在remi safe源中的,因此需要同时配置remi源和remi safe源,remi safe中存放的是安装php过程中可能需要的包以及其他相关工具,例如依赖包libzip5、php容器php-fpm。

[root@linuxidc ~]# cat /etc/yum.repos.d/remi.repo[remi]name=remirepobaseurl=https://mirrors.tuna.tsinghua.edu.cn/remi/enterprise/6/php56/x86_64/enable=1gpgcheck=0

[remisafe]name=remisaferepobaseurl=https://mirrors.tuna.tsinghua.edu.cn/remi/enterprise/6/safe/x86_64/enable=1gpgcheck=0

再yum安装就一路顺利了。yum --disablerepo=* --enablerepo=remi* -y install php php-fpm

Red Hat Enterprise Linux 7.3下PHP安装 https://www.linuxidc.com/Linux/2017-05/143942.htm《细说PHP》高清扫描PDF+光盘源码+全套教学视频 https://www.linuxidc.com/Linux/2014-03/97536.htmCentOS 7.3环境下PHP7.0安装 https://www.linuxidc.com/Linux/2017-08/146433.htmCentOS 7.2下编译安装PHP7.0.10+MySQL5.7.14+Nginx1.10.1 https://www.linuxidc.com/Linux/2016-09/134804.htmLinux安装PHP5与PHP7共存 https://www.linuxidc.com/Linux/2018-01/150007.htmLinux安装PHP扩展模块详解 https://www.linuxidc.com/Linux/2018-01/150006.htmCentOS 7 下 PHP 7.1.12 安装配置 https://www.linuxidc.com/Linux/2018-01/150508.htmCentOS 7 下使用 MySQL 5.7 + PHP 7 + Apache 部署 Nextcloud https://www.linuxidc.com/Linux/2017-12/149945.htmUbuntu 17.10上安装LEMP环境(Nginx,MariaDB,PHP7.1) https://www.linuxidc.com/Linux/2017-12/149581.htm

PHP 的详细介绍:请点这里PHP 的下载地址:请点这里

本文永久更新链接地址:https://www.linuxidc.com/Linux/2018-03/151312.htm

linux 12下一页

Linux公社的RSS地址http://www.it56.cn/rss.xml

本文永久更新链接地址www.it56.cn/Apache/2197.html

linux